Configuring Frame Relay in GNS3 with OSPF
Today I have been configuring frame relay in GNS3.
My setup is one frame relay switch with one virtual frame relay circuit, point to point.
Here is the configuration for the interfaces on R1 and R2.
Notice the clock rate is specified on both R1 and R2. This is not an error as GNS3 is unable to simulate DTE and DCE interfaces properly. I belive this works fine in Packet Tracer though.
Here is the configuration for OSPF for routers R1 and R2
Here is the output of various 'show frame-relay' commands for both routers.
I have posted this as I thought it might be useful to someone who wants to briefly study the configuration.
Hope it helps!!!
My setup is one frame relay switch with one virtual frame relay circuit, point to point.
R1#sh run | sec interface Serial0/0
interface Serial0/0
no ip address
encapsulation frame-relay
clock rate 2000000
cdp enable
interface Serial0/0.1 point-to-point
ip address 192.168.1.254 255.255.255.252
frame-relay interface-dlci 101
R1#
R1#sh run | sec interface Loopback1
interface Loopback1
ip address 172.16.1.1 255.255.255.0
R1#
R2#sh run | sec interface Serial0/0
interface Serial0/0
no ip address
encapsulation frame-relay
clock rate 2000000
cdp enable
interface Serial0/0.1 point-to-point
ip address 192.168.1.253 255.255.255.252
frame-relay interface-dlci 202
R2#
R2#sh run | sec interface Loopback1
interface Loopback1
ip address 172.16.2.1 255.255.255.0
R2#
Notice the clock rate is specified on both R1 and R2. This is not an error as GNS3 is unable to simulate DTE and DCE interfaces properly. I belive this works fine in Packet Tracer though.
Here is the configuration for OSPF for routers R1 and R2
R1#sh run | sec ospfR2#sh run | sec ospf
router ospf 100
router-id 11.0.0.0
log-adjacency-changes
network 172.16.1.0 0.0.0.255 area 0
network 192.168.1.252 0.0.0.3 area 0
R1#
router ospf 100
router-id 10.0.0.0
log-adjacency-changes
network 172.16.2.0 0.0.0.255 area 0
network 192.168.1.252 0.0.0.3 area 0
R2#
Here is the output of various 'show frame-relay' commands for both routers.
Here is the output for 'show ip route' on both routersR1#sh frame-relay map
Serial0/0.1 (up): point-to-point dlci, dlci 101(0x65,0x1850), broadcast
status defined, active
R1#sh frame-relay lmi
LMI Statistics for interface Serial0/0 (Frame Relay DTE) LMI TYPE = ANSI
Invalid Unnumbered info 0 Invalid Prot Disc 0
Invalid dummy Call Ref 0 Invalid Msg Type 0
Invalid Status Message 0 Invalid Lock Shift 0
Invalid Information ID 0 Invalid Report IE Len 0
Invalid Report Request 0 Invalid Keep IE Len 0
Num Status Enq. Sent 159 Num Status msgs Rcvd 156
Num Update Status Rcvd 0 Num Status Timeouts 3
Last Full Status Req 00:00:26 Last Full Status Rcvd 00:00:26
R1#sh frame-relay pvc
PVC Statistics for interface Serial0/0 (Frame Relay DTE)
Active Inactive Deleted Static
Local 1 0 0 0
Switched 0 0 0 0
Unused 0 0 0 0
DLCI = 101, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.1
input pkts 226 output pkts 240 in bytes 25460
out bytes 27109 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 209 out bcast bytes 23929
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:26:16, last time pvc status changed 00:25:43
R1#R2#sh frame-relay map
Serial0/0.1 (up): point-to-point dlci, dlci 202(0xCA,0x30A0), broadcast
status defined, active
R2#sh frame-relay lmi
LMI Statistics for interface Serial0/0 (Frame Relay DTE) LMI TYPE = ANSI
Invalid Unnumbered info 0 Invalid Prot Disc 0
Invalid dummy Call Ref 0 Invalid Msg Type 0
Invalid Status Message 0 Invalid Lock Shift 0
Invalid Information ID 0 Invalid Report IE Len 0
Invalid Report Request 0 Invalid Keep IE Len 0
Num Status Enq. Sent 269 Num Status msgs Rcvd 266
Num Update Status Rcvd 0 Num Status Timeouts 3
Last Full Status Req 00:00:15 Last Full Status Rcvd 00:00:15
R2#sh frame-relay pvc
PVC Statistics for interface Serial0/0 (Frame Relay DTE)
Active Inactive Deleted Static
Local 1 0 0 0
Switched 0 0 0 0
Unused 0 0 0 0
DLCI = 202, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.1
input pkts 203 output pkts 212 in bytes 22853
out bytes 23512 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 197 out bcast bytes 21952
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:22:58, last time pvc status changed 00:22:58
R2#
Here is output for 'show ip ospf database' and 'show ip ospf interface'. This has been executed on both routers.R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.1.0/24 is directly connected, Loopback1
O 172.16.2.1/32 [110/65] via 192.168.1.253, 00:22:42, Serial0/0.1
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.252 is directly connected, Serial0/0.1
R1#R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
O 172.16.1.1/32 [110/65] via 192.168.1.254, 00:22:04, Serial0/0.1
C 172.16.2.0/24 is directly connected, Loopback1
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.252 is directly connected, Serial0/0.1
R2#
R1#sh ip ospf database
OSPF Router with ID (11.0.0.0) (Process ID 100)
Router Link States (Area 0)
Link ID ADV Router Age Seq# Checksum Link count
10.0.0.0 10.0.0.0 1522 0x80000003 0x00DA0B 3
11.0.0.0 11.0.0.0 1521 0x80000001 0x00C620 3
R1#sh ip ospf interface
Loopback1 is up, line protocol is up
Internet Address 172.16.1.1/24, Area 0
Process ID 100, Router ID 11.0.0.0, Network Type LOOPBACK, Cost: 1
Loopback interface is treated as a stub Host
Serial0/0.1 is up, line protocol is up
Internet Address 192.168.1.254/30, Area 0
Process ID 100, Router ID 11.0.0.0, Network Type POINT_TO_POINT, Cost: 64
Transmit Delay is 1 sec, State POINT_TO_POINT
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:06
Supports Link-local Signaling (LLS)
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 10.0.0.0
Suppress hello for 0 neighbor(s)
R1#R2#sh ip ospf data
OSPF Router with ID (10.0.0.0) (Process ID 100)
Router Link States (Area 0)
Link ID ADV Router Age Seq# Checksum Link count
10.0.0.0 10.0.0.0 1564 0x80000003 0x00DA0B 3
11.0.0.0 11.0.0.0 1565 0x80000001 0x00C620 3
R2#sh ip ospf database
OSPF Router with ID (10.0.0.0) (Process ID 100)
Router Link States (Area 0)
Link ID ADV Router Age Seq# Checksum Link count
10.0.0.0 10.0.0.0 1567 0x80000003 0x00DA0B 3
11.0.0.0 11.0.0.0 1568 0x80000001 0x00C620 3
R2#sh ip ospf interface
Loopback1 is up, line protocol is up
Internet Address 172.16.2.1/24, Area 0
Process ID 100, Router ID 10.0.0.0, Network Type LOOPBACK, Cost: 1
Loopback interface is treated as a stub Host
Serial0/0.1 is up, line protocol is up
Internet Address 192.168.1.253/30, Area 0
Process ID 100, Router ID 10.0.0.0, Network Type POINT_TO_POINT, Cost: 64
Transmit Delay is 1 sec, State POINT_TO_POINT
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:02
Supports Link-local Signaling (LLS)
Index 2/2, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 11.0.0.0
Suppress hello for 0 neighbor(s)
R2#
I have posted this as I thought it might be useful to someone who wants to briefly study the configuration.
Hope it helps!!!
Comments
Post a Comment