Configuring Cisco CME Voice Gateway (VG) for incoming and outgoing calls using Sipgate trunk

Hi All

For my reference and your's, here is a working sample configuration for configuring sipgate (sipgate.co.uk) for incoming and external VOIP calls on a 2800 series Cisco router.

Using GNS3; My wireless adapter has internet connection sharing enabled, and I have created a loopback adapter which is the 'internet' adapter as you can see below.




I have tested making calls using Cisco's CIPC version 8 and receiving calls. This doesn't have to be done in GNS3, just pick up yourself a real voice gateway.


version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname VG-EP

!

boot-start-marker

boot-end-marker

!

!

aaa new-model

!

!

aaa authentication login http local

aaa authentication login ssh local

aaa authorization exec http local

!

aaa session-id common

!

resource policy

!

memory-size iomem 5

clock timezone GMT 1

no ip icmp rate-limit unreachable

ip cef

ip tcp synwait-time 5

!

!

!

!

ip domain name myn.local

ip name-server 8.8.8.8
crypto key generate rsa general-keys modulus 1024

ip ssh version 2

!

!

!

voice service voip

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

redirect ip2ip

sip

registrar server expires max 1200 min 60

!

!

voice class codec 1

codec preference 1 g729r8

!


!

voice translation-rule 1

rule 1 /^9/ //

!

!
voice translation-rule 2
 rule 1 // /9/
!
voice translation-profile INCOMING
translate calling 2

!

voice translation-profile OUTGOING

translate called 1
!

!

!

crypto pki trustpoint TP-self-signed-4279256517

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-4279256517

revocation-check none

rsakeypair TP-self-signed-4279256517

!

!

crypto pki certificate chain TP-self-signed-4279256517

certificate self-signed 01 nvram:IOS-Self-Sig#3704.cer

username admin privilege 15 password 0 admin

!

!

!

!

!

interface FastEthernet0/0

ip address 192.168.0.100 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

ip address dhcp

duplex auto

speed auto

no cdp enable

!

ip route 0.0.0.0 0.0.0.0 192.168.137.1

!

ip http server

ip http authentication aaa login-authentication http

ip http authentication aaa exec-authorization http

ip http secure-server

ip http path flash:/cme

ip dns server

!

!

!

!

control-plane

!

!

!

!

!

!

!

dial-peer voice 2 voip

description *Outbound to Sipgate*

translation-profile outgoing OUTGOING
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte

destination-pattern 9.T


session protocol sipv2

session target dns:sipgate.co.uk

session transport udp

dtmf-relay rtp-nte

clid network-number 000000 ! Put your SIP-ID here. (all calls to Sipgate will go via your account id)

no vad

!

dial-peer voice 1 voip

description *Incoming from Sipgate*
translation-profile incoming INCOMING
voice-class codec 1

voice-class sip dtmf-relay force rtp-nte

session protocol sipv2

incoming called-number .%

dtmf-relay rtp-nte

ip qos dscp cs5 media

ip qos dscp cs4 signaling

no vad

!

!

sip-ua


credentials username myaccountid password myaccountpassword realm sipgate.co.uk

authentication username myaccountid password myaccountpassword

no remote-party-id

retry invite 5

retry register 10

timers connect 100

registrar dns:sipgate.co.uk:5060 expires 3600

sip-server dns:sipgate.co.uk:5050

!

!

telephony-service

srst mode auto-provision none

max-ephones 10

max-dn 20

ip source-address 192.168.0.100 port 2000

system message Cisco Unified CME Test Lab

time-zone 22

date-format dd-mm-yy

max-conferences 8 gain -6

web admin system name admin password
 admin

dn-webedit

time-webedit

transfer-system full-consult

!

!

ephone-dn 1

number 100

label 100 Reception

name Recept

!

!

ephone-dn 2

number 101

label 101 ITICS

name ITICS

!

!

ephone-dn 3

number 102

label 102 Marketing

name Marketing

!

!

ephone-dn 4

number 103

label 103 Finance

name Finance

!

!

ephone-dn 5

number 0000000 !SipID

label 0151XXXXXXX

name 0151XXXXXXX

!

!

ephone 1

description WifiPhone


mac-address 001D.E0D6.1111

type CIPC

button 1:1 2:2 3:5

!

!

!

ephone 2

description XP CIPC

mac-address 000C.29C2.3463

button 1:3 2:4

!

!

!

line con 0

exec-timeout 0 0

privilege level 15

logging synchronous

line aux 0

exec-timeout 0 0

privilege level 15

logging synchronous

line vty 0 4

privilege level 15

login authentication ssh
logging synchronous

transport input all

!

ntp clock-period 17179938

ntp server 85.119.80.232

!

end

Immensely proud! 


Comments

Post a Comment

Popular posts from this blog

Create bootable CUC CUCM CUP Image / ISO

Configuring Oracle 12c backups on Veritas Backup Exec 16.

CUCM 11.5 - Esxi 6.5 - unable to create VM